Node 104 Singapore Outage Friday 13th January 2017 22:25:00 UTC

We're investigating an outage on Node 104 Singapore affecting a small number of Minecraft servers.

Update @ 22:50 UTC: We're performing hardware tests before bringing servers back online to identify the root cause.

Update @ 23:30 UTC: Servers have been brought back online. We'll schedule a maintenance to address a possible hardware issue overnight (Singapore time).